
 
 

 
 

 
What is Simulink? 
 
Simulink, an add-on product to MATLAB, provides an interactive, graphical 
environment for modeling, simulating, and analyzing of dynamic systems.  It enables 
rapid construction of virtual prototypes to explore design concepts at any level of detail 
with minimal effort. For modeling, Simulink provides a graphical user interface (GUI) 
for building models as block diagrams.  It includes a comprehensive library of pre-
defined blocks to be used to construct graphical models of systems using drag-and-drop 
mouse operations.  The user is able to produce an “up-and-running” model that would 
otherwise require hours to build in the laboratory environment. It supports linear and 
nonlinear systems, modeled in continuous-time, sampled time, or hybrid of the two.  
Since students learn efficiently with frequent feedback, the interactive nature of Simulink 
encourages you to try things out, you can change parameters “on the fly” and 
immediately see what happens, for “what if” exploration.  Lastly, and not the least, 
Simulink is integrated with MATLAB and data can be easily shared between the 
programs.   
 
 
 

 
 
In order to use Simulink, you must first start MATLAB.  With MATLAB running, there 
are two ways to start Simulink: 
 
• Click the Simulink icon  on the MATLAB toolbar 
• Type  ‘simulink’ at the MATLAB prompt followed by a carriage return (press the 

Enter key) 
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In response, MATLAB displays the Simulink Library Browser.  
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Next, select New Model from the File pull-down menu in the Library Browser.  The 
following blank window appears on your screen.  We will refer to this window as the 
model window. 
 

 
 
In this model window, models are drawn and edited mainly by mouse driven commands. 
 
 
 
 

 
 
There are two major categories of elements in Simulink: 
• Blocks 
• Lines 
 
Blocks are used to generate, modify, combine, output, and display signals.  Lines, on the 
other hand, are used to transfer signals from one block to another. 
 
Blocks 
 
There are several general classes of blocks, some of which are: 
 
• Sources: Used to generate various signals.  Sources blocks have outputs but no 

inputs.       One may want to use a Constant input, a Sine Wave, a Step, a Ramp, a 
Pulse Generator, or a Uniform Random number to simulate noise.  The Clock may be 
used to create a time index for plotting purposes. 

• Sinks: Used to output or display signals.  Sinks blocks have inputs but no outputs.  
Examples are Scope, Display, To Workspace, Floating Scope, XY Graph, etc. 

• Discrete: Discrete Filter, Discrete State-Space, Discrete Transfer Fcn, Discrete Zero-
Pole, Unit Delay, etc. 

• Continuous: Integrator, State-Space, Transfer Fcn, Zero-Pole, etc. 
• Signal routing: Mux, Demux, Switch, etc. 
• Math Operations: Abs, Gain, Product, Slider Gain, Sign, Sum, etc. 
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Lines 
 
Lines transmit signals in the direction indicated by the arrow.  Lines must always 
transmit signals from the output terminal of one block to the input terminal of another 
block.  One exception to this is that a line can tap off of another line.  This sends the 
original signal to two (or more) destination blocks. 
 
Lines can never inject a signal into another line; lines must be combined through the use 
of block such as a summing junction.  A signal can be either a scalar signal or a vector 
signal. 
 
 
 
 

    
 
- Building a Simulink model 
 
Building a Simulink model of a system consists of selecting the appropriate blocks and 
connecting them in a way that represents the mathematical models. 
Since the best way to learn a simulation tool is to work with it, this first tutorial will 
guide you through a simple example.  We will build the block diagram for a simple 
model consisting of a sinusoidal input multiplied by a constant gain, which is depicted 
below. 
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Six Distinct Blocks 
 
The Simulink model will consist of 6 distinct blocks, namely, Sine Wave, Scope, Mux, 
Clock, and To Workspace.  The Sine Wave is a source block from which a sinusoidal 
input signal originates.  The signal is transferred through a line in the direction indicated 
by the arrow to the Gain block.  The Gain block modifies its input (scales it by 5) and 
outputs a new signal through a line.  The output of the Gain block and the output of the 
Sine Wave are combined in the multiplexer (Mux) to form a signal vector.  The signal 
vector is transferred through a line to the Scope block used to display a signal much like 
an oscilloscope. 
 
Specifications of Model 
 
 

Block Name 
 

Specifications 
 

Location 

 
Sine Wave 
 

Amplitude=1v 
Frequency=1 rad/s 

 
Sources 

 
Scope 

 
Time range=10s 

 
Sinks 

 
Gain 

 
Gain=5 

 
Math Operations 
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Mux 

 
2 Inputs 

 
Signal Routing 

 
Clock 
 

 
None 
 

 
Sources 
 

To Workspace Save Format=Array Sinks 

Simulation Parameters: Stop time=1000; Max step size=0.001 

 
 
 
 
Model Creation 
 
Creating a working model with Simulink is straightforward.  The process involves four 
(4) basic steps as depicted in the following flowchart: 
 

 
 
First you will gather all the necessary blocks from the Library Browser.  Then you will 
modify the blocks so that they correspond to the blocks of the desired model.  Lastly, but 
not the least, you will connect the blocks with lines to form the complete system and set 
the overall simulation parameters.  After this, you will simulate the complete system to 
verify that it works. 
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A. Step one: Select desired blocks –  
Getting the blocks into the model window: 

 
Follow the steps below to collect the necessary blocks: 
 
• Create a new model (New from the File menu). You will get a blank model window 
• Click on the Sources icon in the Library Browser.  This opens the Sources window 

which contains the Sources block library.  Sources are used to generate signals. 
• Drag the Sine Wave and Clock blocks from the Sources window into the left side of 

your model window. 
• Click on the Sinks icon in the Library Browser to open the Sinks window. 
• Drag the Scope and To Workspace blocks into the right side of your model window. 
• Click on the Signal Routing icon in the Library Browser to open the Signal Routing 

window. 
• Drag the Mux block into the your model window 
• Click on the Math Operations icon in the Library Browser to open Math Operations 

window. 
• Drag the Gain block into your model window. 
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B. Step 2: Configure block parameters -  

 Resizing and moving blocks: 
 
• First select the block by clicking with your left mouse button while the pointer is on 

the block.  In each corner of the block a little filled square appears.  Put the pointer on 
one of the corner, press the left mouse button and keep it pressed down.  Move the 
mouse and release the mouse button when the block has the desired size. 

• To move a block you first have to select it.  Then put the pointer inside the block, 
press the left mouse button down and keep it pressed down.  Drag the block to its new 
position and release the mouse button. 

 
 
C. Step 3: Connecting block inputs and outputs- 

Adding a branch line: 
 
To connect the output of the Sine Wave to the input of the Mux block, you will use a 
branch line.  Drawing a branch line is slightly different in that to start, the branch line 
must be welded to an existing line.  Position the pointer on the line that connects the Sine 
Wave block to the Gain block.  Without moving the mouse, press and hold down the 
CTRL key and then press and hold the left mouse button.  Drag the pointer to the input 
port of the Mux block and release the mouse button. 
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D.  Step 4: Configure simulation parameters -  
 
Step 4.1  Adding Annotation: 
 
Annotations add textual information about the designed model.  One can add an 
annotation to any unoccupied area of your block diagram. To create a model annotation, 
double click in an unoccupied area.  A small rectangle appears and the pointer changes to 
a vertical insertion bar.  Start typing the annotation content.  To start a new line, simply 
hit the Enter key.  Each line is centered within the rectangular box that surrounds the 
annotation.  To close the annotation, click with the mouse elsewhere in the window. 
 
In your block diagram you will place a title at the top and you will place your name and 
date at the lower right, as depicted below. 
 
To move an annotation, drag it to a new location.  To change the font size of an 
annotation, select it and with the mouse select Format and then Font.   In the pop-up 
window select the desired font size and then click OK.  The font size will change when 
the annotation is deselected, to do so simply click elsewhere. 
 
 
 

 
 
 
 
Step 4.2 Adding Signal Labels: 
 
Labels can be added o lines to further annotate your model.  To create a signal label, 
double click on a line segment and type the label at the insertion point.  When you click 
on another part of the model, the label fixes its location. 
To move a signal label, point at it with the mouse, press and hold the left mouse button 
and drag the label to a new location.  To unselect a label, click elsewhere in the model. 
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E.  More Modifications 
 
Modify blocks  
 
Follow these steps to properly modify the blocks in your model 
 
• Double-click your Sine Wave.  Change the frequency to 1 rad/s and the amplitude to 

1v.  Close the dialog box. 
• Double-click the Gain block.  Change the gain to 5 and close the dialog box. 
 
Copying blocks: 
 
• Position the pointer on the block to be copied, press the right mouse button down and 

keep it pressed down to copy the block.  Drag the copy of the desired position and 
release the mouse button. 

• Alternatively, you can use Copy and Paste topics of the Edit menu to copy the block 
 
Removing blocks: 
 
• Select the block to be removed 
• Press the Delete key on your keyboard, or select the Cut topic in the Edit menu 
 
Connecting blocks with lines: 
 
Now that the blocks are properly laid out, you will now connect them together.  Follow 
these steps: 
 
• Drag the mouse from the output terminal of the Sine Wave block to the upper input of 

the Sum block. 
• Let go of the mouse button only when the mouse is right on the input terminal.  Do 

not worry about the path you follow while dragging, the line will route itself. 
• The resulting line should have a filled arrowhead.  If the arrowhead is pen, it means it 

is not connected to anything.  You can continue the partial line you just drew by 
treating the open arrowhead as an output terminal and drawing just as before. 
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Run Simulation 
 
Double-click the Scope block, Scope window will pop-up.  Then click Simulation Start, 
you will see the simulation result is plotted in the Scope.  Click Autoscale (an icon of 
Telescope), the Scope will rescale the plot and make it fit the window.  You can also 
Zoom in/out the plot.  You can also rescale the axes; by right click on the axes. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 323



  
 
- Fourier Series Synthesis 
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Simulation Parameters 
 
In the model window, select Configuration Parameters from the Simulation menu, as 
depicted below. 
 

 
 
 
 
You will see the following dialog box. 
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There are many simulation parameter options, we will be concerned with the Start time 
and Stop time, which tell SIMULINK over what time span to perform the simulation. 
Keep the Start time at 0.0, and change the Stop time from 10.0 to 1000.00.  Next, we will 
alter the Max step size. Change Max step size from auto to 0.001.  Close the dialog box 
by clicking OK and run the simulation. 
 
After hitting the Autoscale button  , the Scope window should provide a much better 
display of the output. 
 
 
 
Scope 
 
The scope block displays its input with respect to simulation time.  The Scope block can 
have multiple axis; all axes have a common time range.  You can move and resize the 
Scope window and you can modify the Scope’s parameter values during the simulation.  
When you start a simulation, Simulink does not open Scope windows. 
 
 

 
 
Y-axis Limits 
 
You set Y-limits by right-clicking an axis and choosing Axes Properties.  The following 
dialog box appears: 
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• Y-min: Enter the minimum value for the y-axis 
• Y-max: Enter the maximum value for the y-axis 
• Title: Enter the title of the plot.  You can include a signal label in the title by typing 

%<SignalLabel> as part of the title string. 
 
 
Scope Parameters: 
 
You can alter axis limits, set the number of axes, tick labels, sampling parameters, and 
saving options by choosing Parameters toolbar button, as depicted below. 

 
When you click the Parameters button, the following dialog box appears: 
 

 
 
The dialog box has tow panes: “General” and “Data History”. 
 
General Parameters: 
 
You can set the axis parameters, time, range, and tick labels in the General tab.  You can 
also choose floating Scope option with this tab. 
 
Numbers of axes: 
 
Set the number of y-axes in this data field.  With the exception of the floating Scope, 
there is no limit to the number of axes the Scope block can contain.  Note that the number 
of axes is equal to the number of input ports. 
 
Time range: 
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Change the x-axis limits by entering a number or auto in the Time range field.  Entering a 
number of seconds causes each screen to display the amount of data that corresponds to 
that number of seconds.  Enter auto to set the x-axis to the duration of the simulation. 
 
Tick labels: 
 
You can choose to have tick labels on all axes, or one axis, or on the bottom axis only, 
using the Tick labels list 
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